Symptoom

  • Het rekenmodel ziet er netjes uit, maar de berekeningen lijken onderling niet te kloppen.

Remedie

Hoe lost u het probleem op? In principe zijn er twee manieren:

  • Getallen niet opmaken en niet afronden.
  • Getallen opmaken en afronden.
Bedragen afronden

In het getoonde werkblad moeten de getallen worden opgemaakt (als geldbedragen) en `moet’ u ze dus ook afronden. In het in de figuur getoonde werkblad staat in cel G3 de formule =E3*F3. U rondt het resultaat van deze formule als volgt af:

  1. Verplaats de celwijzer naar de af te ronden cel.
  2. Roep de inhoud van de cel op (door te dubbelklikken of door op functietoets [F2] te drukken).
  3. Typ vóór de bestaande celinhoud =AFRONDEN(
    (een isgelijkteken, de naam van de functie en een ronde openingshaak.
  4. Typ achter de bestaande celinhoud ;2)
    Met het cijfer 2 geeft u aan dat u wilt afronden op twee decimalen.
  5. Zet de formule weer in de cel door op [Enter] te drukken.
    De inhoud van cel G3 is nu correct:

=AFRONDEN(E3*F3;2)

Behandel de andere cellen met vermenigvuldigingen op dezelfde manier.

Verdieping

Kijk eens naar het werkblad in de figuur. Dit werkblad laat een voorbeeld van de problemen zien. Bij het opstellen van een factuur (D2:G6) moeten de bedragen per artikelregel worden bepaald. De prijs per stuk geeft aan dat de stukprijs is opgegeven met een nauwkeurigheid van vijf cijfers achter de komma. Het bedrag per factuurregel is (uiteraard) een bedrag dat wordt afgebeeld met twee cijfers achter de komma. Omdat Bedrag berekend is door Aantal te vermenigvuldigen met Prijs per stuk, staan in de kolom Bedrag getallen met vijf cijfers achter de komma. De getalopmaak zorgt ervoor dat u er slechts twee ziet. De optelling is fout: € 2,04 + € 8,31 = € 10,35, niet € 10,34.

U moet de waarden, de uitkomsten van de vermenigvuldigingen, dus afronden. Dit doet u met de functie AFRONDEN. Hetgeen afgerond moet worden, moet als argument worden opgegeven, evenals het aantal cijfers achter de komma waarop moet worden afgerond.
De inhoud van cel G6 hoeft niet afgerond te worden. Deze inhoud komt tot stand door het optellen van cellen waarvan de inhoud al is afgerond. Cel G6 bevat dus automatisch een getal met twee cijfers achter de komma. Het is niet verboden de inhoud nog eens af te ronden, maar het is onnodig veel werk. Wél moet de cel een getalopmaak met twee cijfers achter de komma krijgen. Stel dat de optelling zou resulteren in een bedrag van € 10,30. Als de cel geen getalopmaak met twee cijfers achter de komma heeft, wordt 10,3 afgebeeld (ook als u de functie AFRONDEN gebruikt).

Tips

  • De werkbalk Opmaak van Excel 2000-2003 bevat een aantal knoppen waarmee u een celinhoud snel met een vast aantal decimalen kunt afbeelden. Ook bevat de werkbalk twee knoppen om het aantal decimalen te vergroten dan wel te verkleinen.
  • Wilt u een functie (bijvoorbeeld AFRONDEN) gebruiken, maar hebt u niet veel ervaring met het invoeren van functies, gebruik dan de fx-knop op de formulebalk. Klikt u op deze knop, dan verschijnt het dialoogvenster Functie invoeren. Hier zijn de functies ingedeeld in categorieën. Afrondfuncties vindt u in de categorie Wiskunde en trigonometrie.