Symptomen

  • Op het internet zijn diverse voorbeelden van op Excel-gebaseerde enquêtes. Het is echter erg lastig (onmogelijk?) deze enquêtes aan te passen. Telkens wanneer een keuzerondje wordt verplaatst, werkt een gedeelte van de enquête niet meer.
  • Gebruikers zijn bekend met de Werkbalk besturingselementen en maken zelf hun enquêteformuler. Het groeperen van de keuzerondjes zorgt echter voor problemen.

Remedie

Bouw het enquêteformulier zonder gebruik te maken van keuzerondjes:

  1. Open een nieuwe werkmap.
  2. Verwijder alle bladen behalve Blad1: selecteer de te verwijderen bladen een voor een en kies Bewerken, Verwijderen, Blad verwijderen.
  3. Neem de basisenquête over uit onderstaande figuur:

Toelichting: de ‘keuzerondjes’ maakt u door in de betreffende cellen de functie =TEKEN(153) te plaatsen en de cellen vervolgens op te maken met de opdracht Opmaak, Celeigenschappen, klikken op het tabblad Lettertype en in het lijstvak Lettertype Wingdings2 kiezen.

  1. Typ in cel i3 de formule

= ALS(B3=TEKEN(158);1;ALS(C3=TEKEN(158);2

;ALS(D3=TEKEN(158);3;ALS(E3=TEKEN(158);4

;ALS(F3=TEKEN(158);5;0)))))

  1. Kopieer deze formule naar de overige cellen in kolom i.
  2. Pas de vragen in kolom A naar behoefte aan.
  3. Pas de opmaak van het enquêteformulier aan.
  4. Druk op [Alt]+[F11] om de Visual Basic Editor te activeren: u gaat twee mini-programmaatjes maken.
  5. Dubbelklik in de Projectverkenner (het smalle venster aan de linkerkant van het scherm) op Blad1 (Blad1):
  6. Neem de volgende programmaopdrachten over in het grote witte venster aan de rechterkant:
  7. Dubbelklik in de Projectverkenner op ThisWorkbook:
  8. Neem de volgende programmaopdrachten over in het venster aan de rechterkant:
  9. Kies Bestand, Sluiten en terugkeren naar Microsoft Excel.
  10. Kies Bestand, Opslaan als en sla de enquête op onder een zelfgekozen naam.

Verdieping

U kunt de enquête testen door in cel A1 een andere tekst te typen, bijvoorbeeld Mijn enquête.

Klikt u vervolgens achter de vragen op de cellen van uw keuze, dan worden de keuzerondjes ‘geselecteerd’. Bovendien wordt in kolom i gerapporteerd welke keuze op deze regel is gemaakt:

Andere versies

In Excel 2007 en hoger gaat u op soortgelijke wijze te werk. Belangrijk is echter dat u de enquête met de programmaopdrachten opslaat als Excel-werkmap met macro’s (*.xlsm). Slaat u de enquête op als een gewone Excel werkmap, dan worden de programmaopdrachten verwijderd!

Tips

  • Wilt u de enquête wijzigen, dan hoeft ui alleen maar het woord Onderhoud in cel A1 te typen.
  • Voeg geen kolommen in links van kolom B. Doet u dit toch, dan moet u de getallen in de programmaregel For i = 2 To 6 aanpassen: verhoog de getallen 2 en 6 met het aantal ingevoegde kolommen.
  • De keuzerondjes die uit de werkset Besturingselementen zijn gehaald (zie Symptomen), dient u uitsluitend te gebruiken binnen zelfgemaakte dialoogvensters. Daar hebt u ook de mogelijkheid de keuzerondjes in groepsvakken te organiseren, zodat ze correct werken.

Zie ook

Werkset besturingselementen.

Zelf dialoogvensters maken